月別アーカイブ: 2014年11月

YosemiteにアップデートしたらPostgreSQLが繋がらなくなった。

MacをYosemiteにアップデートすると自動的にYosemiteのPostgreSQLを読もうとするらしく、それまで使ってた(HomebrewでインストールしたものやAppバージョンの)PostgreSQLが繋がらなくなります。

方法としては2つ。

1:Yosemite用のPostgreSQLを使うようにする。
2:.bashrcなどを使ってPostgreSQLの場所を指定する。

実は始め2を使って処理しましたが、この度Yosemiteのアップデートがあり実行したら元に戻ってしまった。うーん。毎回だと面倒。ということで1にシフト。

YosemiteのPostgreSQLをいきなり起動しようとすると怒られるので、ディレクトリを作ってあげる必要があるらしい。

情報はこちらから↓

http://foobartel.com/2014/10/yosemite-upgrade-postgresql/