カテゴリー別アーカイブ: postgresql

YosemiteにアップデートしたらPostgreSQLが繋がらなくなった。

MacをYosemiteにアップデートすると自動的にYosemiteのPostgreSQLを読もうとするらしく、それまで使ってた(HomebrewでインストールしたものやAppバージョンの)PostgreSQLが繋がらなくなります。

方法としては2つ。

1:Yosemite用のPostgreSQLを使うようにする。
2:.bashrcなどを使ってPostgreSQLの場所を指定する。

実は始め2を使って処理しましたが、この度Yosemiteのアップデートがあり実行したら元に戻ってしまった。うーん。毎回だと面倒。ということで1にシフト。

YosemiteのPostgreSQLをいきなり起動しようとすると怒られるので、ディレクトリを作ってあげる必要があるらしい。

情報はこちらから↓

http://foobartel.com/2014/10/yosemite-upgrade-postgresql/

 

PostgreSQLがOSXで動かなくなった件

Ruby on Rails環境をOSXのローカル上に構築していたのですが、
OSをアップデートしたらPostgreSQLが動かなくなりました。。

直接OSのアップデートが原因なのかは不明。

で、下記の記事を参考にpostmaster.pidを削除して
再起動したら動きました。

http://stackoverflow.com/questions/13755965/after-osx-10-8-upgrade-postgres-can-not-connect-to-the-server

このトピックを書いた人は動いてないようですが、
私のマックには効果ありでした。

OSXはapp版を使うのがいいんですかねー?